] ]

 
] ] ]
]
Welcome Guest ]
]
] ]

] ] ]
]
Site Navigation ]
]
] ]

] ] ]
]
Top 10 Recent Posts ]
View Last Post Murray Chris Craft Constellations
Pages 1 2 3 4 ... 149 » 150
Last Post By: Capt Jim
Forum: Chris Craft

Posted: Today at: 11:06

View Last Post 1991 Four Winns 365
Last Post By: Blue Moon 138
Forum: Four Winns

Posted: July 16 2014 at: 17:35

View Last Post Seat Cushions
Last Post By: Michael Acord
Forum: Sea Fox

Posted: June 06 2014 at: 16:02

View Last Post Sail cleanin’ and hull patchin’
Last Post By: dad21dawg
Forum: Hunter

Posted: May 29 2014 at: 16:01

View Last Post 1983 25’ Chris Craft Catalina
Last Post By: fred6963
Forum: Chris Craft

Posted: May 27 2014 at: 14:26

View Last Post 1963 Constellation 42
Last Post By: spellbound
Forum: Chris Craft

Posted: May 06 2014 at: 08:31

View Last Post Viking Yachts Links
Last Post By: Viking44
Forum: Viking Yacht

Posted: April 17 2014 at: 06:32

View Last Post Amerosport 320
Last Post By: Jerry737
Forum: Chris Craft

Posted: April 13 2014 at: 16:00

View Last Post Any Uniflite Owners near Berkeley CA???
Last Post By: concordian
Forum: Uniflite

Posted: March 08 2014 at: 02:27

View Last Post Inverter
Last Post By: eshover
Forum: Chris Craft

Posted: February 03 2014 at: 11:32

]
] ]
   
Chris Craft
 BoatUS Boat Groups/Manufacturer Forums>>Chris Craft
Subject Topic: Starter Post ReplyPost New Topic
 
] ] ]
]
Author
Message Prev Topic | Next Topic 
salmonpro
"Seaman"




Joined: June 20 2011
Posts: 59
Posted: June 20 2011 at 11:47 | IP Logged Quote salmonpro

Hello,

 

I am new to the forum. I have a CC 25' Catalina that I have now owned for about 1 year. everything mechanically was great until about three days ago when I went to take a cruise and all she would do is "click" when I went to start her.  I looked at my battery connections and found that one of my terminals had been melted right off. I replaced all the cables from my battery to battery selector and all the cables from the block and selonoid so virtually every large cable is now new. went to start and all I got was "Click".  So long story short after testing selonoid and everything I have come to the conclusion the starter is shot. Now for the question...... How do you get that out of there? do I have to pull the motor it looks like the stringers are in the way.

 

Thanks in advace for any answers.



__________________
25' CC catalina
"Aquaholic"
Appleton, WI
Back to Top Printable version View salmonpro's Profile Search for other posts by salmonpro
 
Fly Bridge
"Navigator"




Joined: April 17 2011
Posts: 339
Posted: June 21 2011 at 10:10 | IP Logged Quote Fly Bridge

SALMONPRO:   Good question.  However you are in luck!!  There is a CATALINA forum here on BoatUS.  Click in the CHRIS CRAFT section, then look for CATALINA.  There is a LOT of good answers, and nice group of Cat owners there, ready to help.  Just re-post your starter-removal question there.  See you there in the Catalina section, and WELCOME ABOARD!!!!   

Fly Bridge



Edited by Fly Bridge on June 21 2011 at 10:11


__________________
1979 Chris Craft,Catalina Sedan FB, 33ft. 2 Helms, 2/5.7. New 2004. Port eng. removed to rebuild. Starboard operating. Presently in "Backyard Dry Dock". Home Port:Holiday,Florida. (danbushey@msn.com)
Back to Top Printable version View Fly Bridge's Profile Search for other posts by Fly Bridge
 
]
] ]
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic

] ] ]
]
  ]
Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum
]
] ]

] ] ]
]
©2014, Boat Owners Association of The United States. All Rights Reserved.
This page was generated in 1.1250 seconds.
]
] ]