] ]

 
] ] ]
]
Welcome Guest ]
]
] ]

] ] ]
]
Site Navigation ]
]
] ]

] ] ]
]
Top 10 Recent Posts ]
View Last Post Viking Yachts Links
Last Post By: Viking44
Forum: Viking Yacht

Posted: April 17 2014 at: 06:32

View Last Post Amerosport 320
Last Post By: Jerry737
Forum: Chris Craft

Posted: April 13 2014 at: 16:00

View Last Post Murray Chris Craft Constellations
Pages 1 2 3 4 ... 149 » 150
Last Post By: David Ross
Forum: Chris Craft

Posted: March 14 2014 at: 17:23

View Last Post Any Uniflite Owners near Berkeley CA???
Last Post By: concordian
Forum: Uniflite

Posted: March 08 2014 at: 02:27

View Last Post Inverter
Last Post By: eshover
Forum: Chris Craft

Posted: February 03 2014 at: 11:32

View Last Post 1963 Constellation 42
Last Post By: eshover
Forum: Chris Craft

Posted: February 03 2014 at: 11:19

View Last Post 2000 Gulfstream 232
Last Post By: DanDDan
Forum: Grady-White

Posted: January 30 2014 at: 11:01

View Last Post Catalina Owners
Pages 1 2 3 4 ... 191 » 192
Last Post By: Happy Hour III
Forum: Chris Craft

Posted: January 18 2014 at: 20:11

View Last Post 50 amp question
Last Post By: Pats2nd Connie
Forum: Chris Craft

Posted: January 13 2014 at: 17:57

View Last Post Leaving boat
Last Post By: Pats2nd Connie
Forum: Chris Craft

Posted: January 13 2014 at: 08:17

]
] ]
   
Chris Craft
 BoatUS Boat Groups/Manufacturer Forums>>Chris Craft
Subject Topic: No start, just clicking noise!? Post ReplyPost New Topic
 
] ] ]
]
Author
Message Prev Topic | Next Topic 
soundrunner
"Seaman Recruit"




Joined: July 20 2009
Posts: 7
Posted: August 22 2009 at 09:47 | IP Logged Quote soundrunner

Hello everyone.

 

trying to get in the water this season...ugh.

 

The boat only makes a click noise when i turn the key...starter? Any way to get a test and get a workaround so i can test motor while on land?

 

Thanks!



__________________
William Stamm
Deep River, CT
Back to Top Printable version View soundrunner's Profile Search for other posts by soundrunner
 
boatman66
"Commander"




Joined: August 19 2007
Posts: 1132
Posted: August 22 2009 at 11:17 | IP Logged Quote boatman66

YEH FIRST CHECK BATTERY AND MAKE SURE IT IS FULLY CHARGED-SECOND HAVE A VOLTAGE TESTER WITH A TWELVE VOLT RANGE ON IT THIRD PUT TESTER ON POWER WIRE TO STARTER,THATS THE BIG FAT WIRE TURN KEY IF VOLTAGE TO THAT WIRE AND JUST STILL CLIKS,REMOVE STARTER AND GET IT FIXED..THERE IS THE SHORTEST ROUTE TO TAKE AS THERE ARE SO MANY COMPONENTS TO THE START SYSTEM THAT IF YOU ARE NOT MECHANICALLY/ELECTRICALLY INCLINED YOU COULD REALLY SCREW THINGS UP OTHER OPTION FIND A MECHANIC THAT KNOWS AND SHELL OUT THE BUCKS IT WILL BE CHEAPER IN THE LONG RUN BELIEVE ME GOOD LUCKTHIS IS MEANT TO HELP YOU NOT DENEGRATE YOU HOW IS CONN? WEATHER ANY BETTER THAN WHEN I WAS UP THERE IN JULY?? 

__________________
1986 294 catalina twin 350's
Back to Top Printable version View boatman66's Profile Search for other posts by boatman66
 
]
] ]
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic

] ] ]
]
  ]
Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum
]
] ]

] ] ]
]
©2014, Boat Owners Association of The United States. All Rights Reserved.
This page was generated in 0.9688 seconds.
]
] ]