] ]

 
] ] ]
]
Welcome Guest ]
]
] ]

] ] ]
]
Site Navigation ]
]
] ]

] ] ]
]
Top 10 Recent Posts ]
View Last Post fuel gauge
Last Post By: Bunka
Forum: Mainship

Posted: August 25 2015 at: 00:12

View Last Post Mainship pilot 30
Last Post By: Bunka
Forum: Mainship

Posted: August 17 2015 at: 06:52

View Last Post Rosborough Ltd Links
Last Post By: Trawler
Forum: Rosborough

Posted: July 31 2015 at: 11:56

View Last Post Bridge electrical problem
Last Post By: Summer Kamp
Forum: Carver

Posted: June 15 2015 at: 19:19

View Last Post Dead Forum?
Last Post By: BudMan53
Forum: CraigCat

Posted: May 30 2015 at: 18:51

View Last Post Transducer location
Last Post By: BudMan53
Forum: CraigCat

Posted: May 23 2015 at: 18:48

View Last Post New (used) CraigCat owner!
Last Post By: BudMan53
Forum: CraigCat

Posted: May 17 2015 at: 19:06

View Last Post Yamaha Links
Last Post By: Ricky242
Forum: Yamaha

Posted: February 21 2015 at: 13:13

View Last Post AMEROSPORT OWNERS
Last Post By: jim paluszynski
Forum: Chris Craft

Posted: February 21 2015 at: 09:12

View Last Post Sportcraft Links
Last Post By: jdabbott58
Forum: Sportcraft

Posted: January 21 2015 at: 09:40

]
] ]
   
Chris Craft
 BoatUS Boat Groups/Manufacturer Forums>>Chris Craft
Subject Topic: ignition system 1878 281 Post ReplyPost New Topic
 
] ] ]
]
Author
Message Prev Topic | Next Topic 
pelica11
"Seaman Recruit"




Joined: May 20 2008
Posts: 1
Posted: May 23 2008 at 09:51 | IP Logged Quote pelica11

Hi fellow Chris Craft owners,

I have been having trouble with the port engin coil over heating and shorting out.  I was told it could be a bad ground, an faulty ignition switch or a short in the wiring somewhere.  I just bought a new coil no luck same out come.  I found a few questionable wires and sloppy connections no luck.  I had a few ignition switches tried them no luck.  I went and bought a new ignition swithch and bingo everything is right on spec.  My question is this the real fix or am I going to experience another electrical problem due to some unknown factor.

Thanks

The Pelican



__________________
Owner of 1979 281 Catalina "The Emerald Lady" it's our get-away home.
Back to Top Printable version View pelica11's Profile Search for other posts by pelica11
 
]
] ]
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic

] ] ]
]
  ]
Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum
]
] ]

] ] ]
]
©2015, Boat Owners Association of The United States. All Rights Reserved.
This page was generated in 0.9844 seconds.
]
] ]