] ]

 
] ] ]
]
Welcome Guest ]
]
] ]

] ] ]
]
Site Navigation ]
]
] ]

] ] ]
]
Top 10 Recent Posts ]
View Last Post Rosborough Ltd Links
Last Post By: Trawler
Forum: Rosborough

Posted: July 31 2015 at: 11:56

View Last Post Bridge electrical problem
Last Post By: Summer Kamp
Forum: Carver

Posted: June 15 2015 at: 19:19

View Last Post Dead Forum?
Last Post By: BudMan53
Forum: CraigCat

Posted: May 30 2015 at: 18:51

View Last Post Transducer location
Last Post By: BudMan53
Forum: CraigCat

Posted: May 23 2015 at: 18:48

View Last Post New (used) CraigCat owner!
Last Post By: BudMan53
Forum: CraigCat

Posted: May 17 2015 at: 19:06

View Last Post Yamaha Links
Last Post By: Ricky242
Forum: Yamaha

Posted: February 21 2015 at: 13:13

View Last Post AMEROSPORT OWNERS
Last Post By: jim paluszynski
Forum: Chris Craft

Posted: February 21 2015 at: 09:12

View Last Post Sportcraft Links
Last Post By: jdabbott58
Forum: Sportcraft

Posted: January 21 2015 at: 09:40

View Last Post Murray Chris Craft Constellations
Pages 1 2 3 4 ... 149 » 150
Last Post By: Capt Jim
Forum: Chris Craft

Posted: August 29 2014 at: 11:06

View Last Post 1991 Four Winns 365
Last Post By: Blue Moon 138
Forum: Four Winns

Posted: July 16 2014 at: 17:35

]
] ]
   
Regal
 BoatUS Boat Groups/Manufacturer Forums>>Regal
Subject Topic: Ethanol Fuel Post ReplyPost New Topic
 
] ] ]
]
Author
Message Prev Topic | Next Topic 
jbarnett
"Seaman Recruit"




Joined: September 07 2006
Posts: 3
Posted: October 12 2006 at 19:58 | IP Logged Quote jbarnett

Anyone out there having problems with the new E-10?  I have a 1997 Regal 2558 Commodore with twin Volvo Penta 3.0 engines and so far no problems.  We've run about 40 hours with what I think is the new stuff.  Right now I'm just using the factory fuel bowl ceramic filters but plan on retrofitting a better filter system before spring next year.
Back to Top Printable version View jbarnett's Profile Search for other posts by jbarnett
 
BillyB
"Seaman Recruit"




Joined: April 27 2007
Posts: 1
Posted: April 27 2007 at 22:05 | IP Logged Quote BillyB

I make sure I use the new enzyme treatment to make sur the e-10 doesn't attract water and it seems to have worked. I used it over 120 hours last season.



__________________
Love my REGAL
Back to Top Printable version View BillyB's Profile Search for other posts by BillyB
 
]
] ]
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic

] ] ]
]
  ]
Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum
]
] ]

] ] ]
]
©2015, Boat Owners Association of The United States. All Rights Reserved.
This page was generated in 1.8906 seconds.
]
] ]